You have tried to change the API from what has been previously released in an SDK. Please fix the errors listed above

这两天老出现这样的错误,传说是java没更新的原因。
在www.talkandroid.com/android-forums/android-development/388-android-source-build-problem-under-ubuntu.html
找到的答案,现在在试,不知道是不是这个原因。

结果未知,更新后仍然有问题,已经clean source code了。

重新获取源码后还是出错,看来是官方源码有点问题了。
在www.xxcl.net/?p=33001找到了方法,做了一下修改,应该没问题了。
感谢“夏汛的博客”

具体的作法是:修改external/apache-http/src/org/apache/http/protocol/HTTP.java 里的 "100-continue"为"100-Continue",其实就是大小写的问题。

标签: 编译, 错误, SDK

评论已关闭